行业资讯 >> 行业资讯详情

巧合?严重RCE漏洞竟被意外修复……

发布时间:2019-06-10作者:阅读次数: 分享到:




小编来报:邮件传输代理Exim存在一个严重漏洞,允许攻击者以root身份在电子邮件服务器上远程运行命令,互联网上近一半电子邮件服务器都受漏洞影响。


据外媒报道,网络安全公司Qualys的安全研究人员透露,一个重要的远程命令执行(RCE)安全漏洞(CVE-2019-10149)影响了超过一半的互联网电子邮件服务器。


该漏洞影响邮件传输代理(MTA)Exim,Exim是运行在电子邮件服务器上的软件,将电子邮件从发件人发送给收件人。Qualys表示,在版本为4.87到4.91的Exim中发现了这一非常危险的漏洞。



根据2019年6月对互联网上所有可见邮件服务器的调查,57%(507,389)的电子邮件服务器运行Exim。该漏洞为远程命令执行,允许本地或远程攻击者以root用户身份在Exim服务器上运行命令。


Qualys表示,本地攻击者可以立即利用这个漏洞,即使是拥有低权限帐户的攻击者也可以利用漏洞。


真正的危险来自远程黑客,他们可以扫描互联网上易受攻击的服务器,接管系统。要远程利用默认配置中的这个漏洞,攻击者必须保持与服务器的连接长达7天。但是由于Exim代码的极端复杂性,不能保证这种利用方法是唯一的,可能存在更快的利用方法。当Exim处于某些非默认配置状态时,远程场景中可以即时利用漏洞。



这个漏洞在2019年2月10日Exim 4.92发布时被意外修复,当Exim团队并不知道修复了这个安全漏洞。


直到最近,Qualys团队在审查Exim旧版本时才发现了这个漏洞。Qualys的研究人员提醒Exim用户将版本更新到4.92,以免服务器被攻击者接管。Qualys称这个漏洞很容易被利用,预计攻击者将在未来几天内提出利用代码。





本文转载自E安全,如有侵权请联系删除


服务热线:400-711-8011
Copyright ©2005-2018 杭州美创科技有限公司. All Rights Reserved. 浙ICP备 09009762号-1